Microsoft Azure Outage affecting all Platforms

Incident Report for Ethos Group

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 20:02 CDT

Monitoring

Ethos Group systems are now working with minor performance issues.

Full functionality may not return until Microsoft establishes a complete recovery.
Posted Oct 29, 2025 - 19:45 CDT

Update

Ethos Group systems are now working with degraded performance.

Full functionality may not return until Microsoft establishes a complete recovery.
Posted Oct 29, 2025 - 17:38 CDT

Update

Microsoft's latest update indicates that their systems could remain non-operational until 6:20 PM CST. Ethos Group systems are now working intermittently. Full functionality may not return until Microsoft establishes a complete recovery.
Posted Oct 29, 2025 - 16:36 CDT

Update

Microsoft stated they are continuing the deployment of last known working configuration.

No ETA for full mitigation.
Posted Oct 29, 2025 - 15:33 CDT

Update

Microsoft stated they are continuing the deployment of last known working configuration.

No ETA for full mitigation.
Posted Oct 29, 2025 - 14:19 CDT

Update

Microsoft stated they have initiated deployment of last known working configuration.

No ETA for full mitigation.
Posted Oct 29, 2025 - 13:16 CDT

Update

Microsoft Azure is experiencing an outage that is effecting all major platforms.
Posted Oct 29, 2025 - 11:42 CDT

Update

Microsoft Azure is experiencing an outage that is effecting all major platforms.
Posted Oct 29, 2025 - 11:24 CDT

Update

Microsoft Azure is experiencing an outage that is effecting all major platforms.
Posted Oct 29, 2025 - 11:22 CDT

Update

Microsoft Azure is experiencing an outage that is effecting all major platforms.
Posted Oct 29, 2025 - 11:14 CDT

Update

Microsoft Azure is experiencing an outage that is effecting all major platforms.
Posted Oct 29, 2025 - 11:13 CDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 11:12 CDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 11:07 CDT

Identified

Microsoft Azure is experiencing an outage that is effecting all major platforms.
Posted Oct 29, 2025 - 11:05 CDT
This incident affected: Ethos Arena (Ethos Menu, Ethos Product Contracting, Ethos Digital Deal Jacket), Consumer Applications (Ethos Pay, Ethos Edge), DMS Integration (Advent DMS Integration, AutoMate DMS Integration, Autosoft DMS Integration, CDK DMS Integration, DealerBuilt DMS Integration, Dealertrack DMS Integration, Dominion DMS Integration, PBS DMS Integration, Reynolds DMS Integration, Tekion DMS Integration), and EGCS, Ethos Portal, Analytics, Ethos Product Pricing, Smart Statements, Connect, Dealer Claims Portal, Dealer Cancels, Cyclops.