CDK Integrations Degraded Performance

Incident Report for Ethos Group

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 13:34 CDT

Investigating

We have received reports from stores using CDK that they are unable to pull deals into Arena/Sales Tech platforms. Our integrations engineers have determined that this is an issue on CDK's end of integrations, and we are working to get this resolved with CDK Support.
Posted Aug 22, 2026 - 17:11 CDT
This incident affected: DMS Integration (CDK DMS Integration).