Smart Identification is slow for some users across Production, Early Access, and Canary rings

Incident Report for Ethos Group

Resolved

This incident has been resolved.
Posted May 01, 2026 - 11:31 CDT

Identified

Smart Identification is showing some slower than normal load times. We are continuing to investigate.
Posted May 01, 2026 - 09:44 CDT

Investigating

We are currently investigating this issue.
Posted May 01, 2026 - 09:32 CDT
This incident affected: Ethos Arena (Ethos Digital Deal Jacket).