SMART ID Not Operational

Incident Report for Ethos Group

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2025 - 18:09 CDT

Update

We are continuing to investigate this issue.
Posted Jul 01, 2025 - 13:30 CDT

Investigating

We are currently investigating this Smart Identify issue in Deal Jacket.
Posted Jul 01, 2025 - 13:29 CDT
This incident affects: F&I Menu and Deal Jacket.