Phone System Issues

Incident Report for Ethos Group

Resolved

Our phone system provider has stated that this issue has been resolved. We are showing that our phones are operational.
Posted Jun 12, 2025 - 17:09 CDT

Investigating

This issue is being investigated by our provider.
Posted Jun 12, 2025 - 13:29 CDT
This incident affected: Ethos Group Phones.