Outage affecting Ethos Technology Platform

Incident Report for Ethos Group

Resolved

Service performance has been restored across all platforms.
Posted May 27, 2026 - 21:53 CDT

Update

Service performance is increasing across most platforms. Our engineering teams are continuing to implement a permanent fix.
Posted May 27, 2026 - 21:22 CDT

Update

We are continuing to investigate this issue.
Posted May 27, 2026 - 21:18 CDT

Investigating

We are currently investigating this issue.
Posted May 27, 2026 - 17:18 CDT

Update

We are continuing to monitor for any further issues.
Posted May 27, 2026 - 17:11 CDT

Monitoring

Service performance across all platforms is now stable and being actively monitored.
Posted May 27, 2026 - 16:49 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2026 - 16:37 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2026 - 15:50 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2026 - 15:39 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2026 - 15:34 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2026 - 15:32 CDT

Identified

Our engineering teams have implemented a fix that is currently being tested. Service restoration is in progress.
Posted May 27, 2026 - 15:08 CDT

Update

Our engineering teams have identified the cause of the issue. Resources are currently focused on implementing a solution.
Posted May 27, 2026 - 13:58 CDT

Investigating

We are currently investigating an issue affecting the Ethos Technology Platform.
Posted May 27, 2026 - 13:40 CDT
This incident affected: Ethos Arena (Ethos Menu, Ethos Product Contracting, Ethos Digital Deal Jacket), Consumer Applications (Ethos Pay, Ethos Edge), and EGCS, Ethos Portal, Analytics, Ethos Product Pricing, Smart Statements, Connect, Dealer Claims Portal, Dealer Cancels, Cyclops.