Dealer Claim Portal Issue

Incident Report for Ethos Group

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 20:43 CDT

Investigating

We are currently investigating Dealer Claim Portal.
Posted Jul 07, 2026 - 19:10 CDT
This incident affected: Dealer Claims Portal.