EGA Dashboard Doubling Units for CDK

Incident Report for Ethos Group

Resolved

Our engineering teams have implemented a fix for this issue in the EGA Dashboard and testing has confirmed counts are correct.
Posted May 30, 2026 - 09:37 CDT

Update

We are continuing to monitor for any further issues.
Posted May 29, 2026 - 20:02 CDT

Monitoring

Our engineering teams have implemented a fix for this issue and are monitoring. When checking EGA Dashboard to EGA Reporting after this fix was implemented, counts to appear to be correct in both.
Posted May 29, 2026 - 19:41 CDT

Investigating

We have received multiple reports from dealerships using CDK that their EGA Dashboard is showing incorrect counts while EGA Reporting is showing correct counts. Counts are doubling in EGA Dashboard. IT Support has reached out to our Development teams for assistance.
Posted May 09, 2026 - 12:38 CDT
This incident affected: Analytics.